U

JobTraQ X5.12.3 Release Announcement

Important: Upgrade Prerequisite Previous versions of JobTraQ BPM software only required version 2.0 of the Microsoft .NET Framework. JobTraQ X5.12.3 and later require version 3.5 of the .NET Framework. If your server does not have that version installed, you will be...
Schedule Consultation