During installation, HighGear automatically configures IIS using the IIS 6 metabase. In Windows 8 and Windows Server 2012, IIS was updated to version 8. In order to install applications like HighGear that access the IIS Metabase directly, you must enable the optional IIS 6 compatibilty components on your server. Additionally, the default server configuration for IIS 8 does not enable the ASP.NET server components that HighGear and other dynamic .NET applications require.

This article explains how to enable the IIS 6 compatibility components and the required ASP.NET server components on Windows Server 2012 and Server 2012 R2 for HighGear X6.2.1 and above.

  • Open the Server Manager.
  • Click Add roles and features. A wizard will open. As you click Next, it will take you through a sequence of screens.
  • On the Installation Type screen, choose Role-based or feature-based installation.
  • On the Server Selection screen, choose Select a server from the server pool.
  • On the Server Roles screen, check Web Server (IIS).
    • A popup asking to Add features that are required for Web Server (IIS)? may appear.
    • If it appears, click Add Features.
  • On the Features screen, expand .NET Framework 4.7 Features and check ASP.NET 4.7.
  • On the Role Services screen, ensure the following items under Common HTTP Features are checked:
    • Default Document
    • Directory Browsing
    • HTTP Errors
    • Static Content
  • Still on the Role Services screen, ensure these items under Health and Diagnostics are checked:
    • HTTP Logging
  • Still on the Role Services screen, ensure these items under Performance are checked:
    • Static Content Compression
  • Still on the Role Services screen, ensure these items under Security are checked:
    • Request Filtering
  • Still on the Role Services screen, ensure these items under Application Development are checked:
      • .NET Extensibility 4.7
      • WebSocket Protocol
    • ASP.NET 4.7
    • ISAPI Extensions
    • ISAPI Filters
  • Still on the Role Services screen, ensure these items under Management Tools -> IIS 6 Management Compatibility are checked:
    • IIS 6 Metabase Compatibility
    • IIS 6 WMI Compatibility
  • Install the roles and features you selected.

At this point, you may wish to refer to the following support article on how to install HighGear: HighGear Software Installation Instructions